TIG 200 problem. would like to use at least once.

Posted: September 18, 2014 By: 68cst

Home Forums Welding TIG 200 problem. would like to use at least once.

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #35444

    68cst

    Participant

    Got my new TIG 200 in last week, Was stoked to start my c10 project. When i started testing the unit it worked for 5 minutes then started burning up the mild steel. After troubleshooting i found that the argon gas was not flowing when either the foot pedal or thumb switch was depressed. Called for technical assistance and the tech said that the gas solenoid was faulty and would ship one to me. I received a package today but its a manual valve???? i don’t think that is the correct part. While i had access to the original solenoid i put a meter on the solenoid and see 0 voltage going to the solenoid when either foot pedal or thumb switch is pressed so the solenoid isn’t the problem. The problem is coming from the electronics.Tried calling technical assistance back but getting voice mail Was so stoked to start working but looks like it will not be soon…Anyone else have this problem? any help would be greatly appreciated

    update 30 minutes later:
    Got ahold of customer service and they will be replacing the unit.. Thanks Eastwood for standing behind the product.

    Update. Sent the faulty welder back and received the replacement. Cant use the welder because the argon is leaking from the regulator or the hose. Eastwood is supposed to be sending me a replacement regulator and hose. A week later still no regulator or hose. Called Eastwood back and asked about the status and was told they will get the replacement parts out the next day. hope this works, i would like to use the welder.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed