Problem with new Mig 135

Posted: April 2, 2012 By: ALF

Home Forums Ask Eastwood Problem with new Mig 135

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #34258

    ALF

    Participant

    I tried my new MIG 135 today. I am using flux core wire, so I removed the tip to install the apppropriate size and the liner is extending out past the tip of the gun. I tried pushing it in and it compresses but won’t stay in. I was able to get the new tip to thread in anyway and reversed the polarity. The welder operated fine for about 3 tack welds and two welds lasting about 10 seconds each. Then I couldn’t start an arc again. When I pull the trigger the wire feed runs and the wire bounces off the material I am welding. I tried cleaning the material again. Checked the ground. When the wire wire strikes the steel, the end of the wire glows. I was using the recommended setting of Volts F Wire Speed 2.5. I tried turning up the volts to G then H without success. Tried turning up the wire speed. Tried turning it down. I’ve been using a Lincoln at work and never had this problem. Any thoughts? This is getting frustrating. I’m concerned about both the inability to get an arc started and the wire liner.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed