Mig 175 wire feed problem

Posted: February 8, 2011 By: Benchboss

Home Forums Ask Eastwood Mig 175 wire feed problem

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #33354

    Benchboss

    Member

    I have just assembled my new Eastwood mig 175 with spool gun. I think I may have a problem with the wire speed control device. The wire will gain speed properly from the 0 to 5 setting but will not accelerate any faster from the 5 to 10 settings.
    I have tried to loosen the roller tension and also the wire spool tension and even tried it without any wire at all.
    If I turn it to the #10 position it seems like initially wants to go at the max. speed but seems to go back to the mid range level. Sort of seems like it is binding somewhere.
    I should mention that I have not yet tried the spool gun. The problem is with the Mig wire feed.
    I tried e-mailing the help desk but have not heard back from them > 24 hrs. I have tried to call the customer service line but as usual they are too busy to answer and would hopefully get back to me within 24 hrs.
    I had high expectations from this machine but am getting a little frustrated with the lack of after sales service from Eastwood.
    Any of you guy’s have the same problem or can help with some advice before I send it back.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed