Just bought a new Eastwood Plasma and it’s not working

Posted: November 14, 2015 By: trinitydesignandfabricati

Home Forums Ask Eastwood Just bought a new Eastwood Plasma and it’s not working

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #35962

    So, my old Northern Tool plasma died, so I decided I would look into the Eastwood Plasma’s, things started off a bit rocky, seeing as the sales lady mis informed me about the available plasma for the TIG plasma kit, so after purchasing the smaller plasma because I was told the Versa 60 was not available in a package deal, I then saw the Versa 60 as part of a package. Eastwood was unable to cancel the order, so in order to get my bidder work done on time I had to buy the Versa 60 separate and could send back the Versa 40 once it arrived.

    Boxes arrived last night, unpacked the Versa 60 today to do the work I was hired to do. I got the machine all ready, hooked up the compressor and the machine shows no air pressure….??? I disconnected the compressor, checked the fittings and tried again, still no pressure, I turned on the Plasma thinking the pressure gauge only works when it’s powered up, still nothing.

    So one of two things, either I have extremely bad luck with Plasmas or I’m doing something wrong. Of course, Eastwood seems to matter to the hobbyists, and those hobbyists usually work on the weekends, so of course I called Eastwood, and of course they are not open on the weekends.

    So I now own two Eastwood plasmas, one of which I can’t open and one that doesn’t work….

    Am I missing something, is there an internal plug that needs to be removed? Can anyone help, I want this to be ignorance on my part so i can fix the issue and get the work done I was hired to do, otherwise I bought all this equipment and I will end up losing my client

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed