Help! Plasma cutter problem

Posted: December 26, 2014 By: scarypat2001

Home Forums Ask Eastwood Help! Plasma cutter problem

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #35450

    scarypat2001

    Member

    Hi,

    I just purchased a new Versa Cut 40 plasma cutter, and it’s my first experience with that kind of tool.

    I’m having problems cutting 1/8 steel. It actually barely etches metal, even at 40 amp, 60 psi. tried all kind of combinations, does not work at all… I’m far from getting the cutting results I see on most videos!

    I have what seems to be a nice pilot arc, and tried the instruction from a post explaining how to “break-in” the plasma cutter.

    For the steel itself: grinded to bare metal the cutting area and the ground patch, which I put less than 8 inches from the cutting area.

    For the machine:

    1) running on 220, single circuit with 40 amp circuit.
    2) air: got a small dryer at the exit of the compressor – will buy another dryer that I’ll put at the machine entry point, just in case.
    3) amps: tried everything from 20 to 40
    4) pressure: tried anything from 30 to 70 psi.
    5) did not change the nozzle yet – it has barely 30 minutes of trial, but will try that today.

    I saw a post from someone who had similar issues, but there was not conclusion…

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed