Help new eastwood plasma cutter not working

Posted: April 13, 2012 By: dz

Home Forums Ask Eastwood Help new eastwood plasma cutter not working

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #34290

    dz

    Member

    Hello. I received my new eastwood plasma cutter yesterday. I used it for about two minutes before it made a loud pop noise and tripped my breaker (I had it on a dedicated 115v 15amp circuit, I am also using two air/water separators inline before the plasma cutter). After I switched the circuit breaker back on I turned the plasma cutter back on and tried to cut again. As soon as the trigger is pressed on the torch the cutter goes right into overload, no matter what amperage or air pressure setting. The air turns on and it clicks like it should be working but goes right into overload. I tried leaving it alone off unplugged for awhile and tried it again but keeps on doing the same thing. I also noticed a foul aroma after it popped that didn’t last long. I live right outside of philadelphia, would it be possible to have someone at the local store test it out for me and possibly exchange it if its found defective. I had a project I wanted to tackle this weekend and purchased this plasma cutter for it. I frequently use a plasma cutter at work, but obviously that one is too big to take home. Thanks in advance.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed