Eastwood Versa -Cut and Tig 200 Help. Both units dead

Posted: February 26, 2012 By: JimM

Home Forums Ask Eastwood Eastwood Versa -Cut and Tig 200 Help. Both units dead

Viewing 1 post (of 1 total)
  • Author

    Posts

  • #34186

    JimM

    Member

    Hi All. Figured this was as good a place as any to get some help. I didn’t come here to complain, just looking for some assistance. I received the Eastwood combo Plasma/Tig 200 deal recently (was back ordered for weeks. Link to the tools below). Both devices are dead 🙁

    Versa-Cut Plasma: Plugged in and the power light light up on the front switch, but the fan doesn’t come on and it’s dead it seems. Air is hooked up, power is set to about 50%, tried two outlets (20amp 120v). Ground and red wire are connected. Nothing to the cutting head.

    Tig 200: Plugged that in and turned it on… All looked good when I turned the breakers on in the back, the fan turned on, but nothing in the front. The lights were all dead and the torch would not ignite. So clearly it was getting power, but the front panel showed no activity. I tried both the tig torch control and the petal control (swapping connections on the front) with same results. No arc and no basic power lights.

    Can anybody think of anything to check or verify on either one :confused: Read both manuals and the troubleshooting is weak. Didn’t find anything online either. Bummer to have to send them back. Waited for a long time to get these units. Thanks for any ideas you may have.

    https://www.eastwood.com/ew-tig200-versa-cut-kit.html

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Top Selling Products

Comments are closed